VLC and PhotoShop

Configuring VLC Player

  • Open your video with VLC Player, if you do not have VLC Player you can download it here.
  • Click the following to allow recording of clips. View > Advanced Controls

001

 


 

Recording video in VLC Player

  • Find the portion of the video you want to record and click the record button, then click it again to stop it

 

002

 

 

 

Importing into PhotoShop

  • Your video probably saved into your My Videos folder by default
  • To import a video open PhotoShop and click File > Import > Video Frames to Layers

Creating the layers for your gif in PhotoShop

  • Now that you have your video imported you have to choose the exact portion you will be using
  • The black bars under the video timeline are what to use to choose the exact time frame
  • PhotoShop will only import up to 500 frames

003

 

 

 

Saving your gif

  • To save your gif go to File > Save For Web

004

 

 


 

Adding Text To A Gif

 

Here is what I do, lets say your first word needs to appear on frame 20, select frame 20, scroll to the last frame, hold shift and select it. This will have all frames active. Turn on the single word layer. Play the frames until the next word is going to come up, and do the same thing of selecting the frame it will first appear on and scroll to the very last frame.
Some other fun things you can do is change the opacity of the text in the first frame it appears (say 33%), then in the second frame make it 66%, this way it appears that the words come in softer.
Check out the “uh uh” in this gif for a good example:

http://gif-explode.com/?explode=http://i.imgur.com/vsSH7Rf.gif

So another common question I get is the easiest way to work with text and not have to create each layer individually.

 

I go to layer 1 and create the text I am going to use for the entire gif. Do any styling that I want for the text, then right click and rasterize layer style (to flatten it). So let’s say the text was “go fuck yourself DaedalusMinion”

 

Once the text is flattened make three copies of this layer (ctrl j three times), so we now have four in total, the three copies and the original. I then go to each layer and highlight a single word select the inverse (ctrl i) and delete. Do this for each of the four layers so one word is left in each layer. Now each word is on it’s own layer with the exact same formatting you chose. Some people prefer to make each text layer one at a time, I do it all together.